Technical Requirements for UL EHSS Courseware and PURE Safety LMS

 

 

UL EHSS Courseware

HTML5 in eLearning is the new industry standard. It offers a mobile-friendly development method that delivers dynamic content, intuitive navigation, faster loading and increased functionality across multiple browsers, devices and screen sizes. HTML5 eLearning can be accessed anywhere, whenever it’s most convenient for the learner. UL EHSS is excited to now offer PURE Safety LMS version 5 (PS5) courses in HTML5. 

HTML5 requires use of modern browsers.  For the following operating systems, these are:

 

 

Operating System Browser
Windows 7, 8, 9, 10
  • Microsoft Internet Explorer 10 or higher (11+ is preferred)
  • Microsoft Edge
  • Chrome (latest version)


Mac OS 10.9
  • Apple Safari 7 or higher
iPad iOS8
  • Safari 7 or higher
Android 4.4 (KitKat) or higher
  • Chrome (latest version)

 

 

 

 

 

 

 

 

 

 

 

For the device playing the content, we recommend a minimum processor speed of 1.5 GHz and RAM of 1 GB. For optimal video playback and loading, we recommend exceeding these minimum requirements.

You should also confirm with your LMS provider that your LMS can support HTML5 content.

The network supporting your LMS will need permission for the following file types:

  • Audio/aac .aac
  • Audio/mp4 .mp4 .m4a
  • Audio/mpeg .mp1 .mp2 .mp3 .mpg .mpeg
  • Audio/ogg .oga .ogg
  • Audio/wav .wav
  • Video/ogg .ogv
  • Video/webm .webm

 

UL EHSS’ HTML5 courses are not guaranteed to play on smartphones at this time. Tablets and computers typically provide the best learning experience.

UL EHSS courseware is packaged according to AICC or SCORM specifications and is designed to work with the majority of Learning Management Systems (LMSs) that support those standards. Specifically, courseware is packaged in AICC version AGR-010, and SCORM version 1.2 and 2004 v3.

 

PURE Safety LMS and On Demand

UL EHSS recommends the following system settings and software to successfully interact with our websites and software. Different content may require settings exceeding these minimums; check with your content provider for their recommendations.

To best meet client needs, UL EHSS uses statistical data from our web visitors and registered users to identify the browsers used. We regularly review this data to determine which browsers to support. UL EHSS supports the following browsers:

 

Operating System Browser
WIndows 7, 8, 9, 10
  • Microsoft Internet Explorer 8, 9, 10, or 11
  • Chrome (latest version)
  • Firefox (latest version)
iPad iOS8
  • Safari (latest version)
Android 4.4 (KitKat) or higher
  • Chrome (latest version)

 

Other browser/platform combinations may also work, but UL EHSS does not attempt to resolve problems with browser/platform combinations other than those listed above.  Browsers that have been developed to comply with the W3C guidelines and specifications, including mobile browsers, should operate successfully.


Your browser must also be:

  • Configured to accept cookies
  • Configured to execute JavaScript
  • Capable of 128-bit SSL encryption


For devices accessing UL EHSS software, these are the hardware requirements:

Requirements Minimum Recommended
Processor 1.2 GHz Intel Pentium 1.8 GHz Intel Pentium
RAM 256MB 1GB
Internet Connection 256 Kbps 10 Mbps
Sounds / Speakers 16-bit 16-bit
Video / Display 65,000 Color 65,000 Color

 


Adobe Reader may also be required for viewing and printing some Training Materials and Diplomas. We recommend keeping this program up to date.

Single sign-on (SSO):

Our SSO solution supports SAML 2.0 and requires port 9031/tcp to be open outbound for client browsers to connect to the UL EHS Sustainability SSO server.